boost system dep

Dependency Availability

Arch Linux
All Versions
boost
 
CentOS
All Versions
Not available
 
Cygwin
All Versions
libboost-devel libboost1.40
 
Debian
Sarge
Not available
Etch
Not available
Lenny
Not available
Squeeze
libboost1.42-all-dev
Wheezy
libboost-all-dev
Jessie
libboost-all-dev
Sid (Unstable)
libboost-all-dev
 
Fedora
17 (Beefy Miracle)
boost-devel
18 (Spherical Cow)
boost-devel
19 (Schrödinger's Cat)
boost-devel
20 (Heisenberg)
boost-devel
Fedora 21
boost-devel
Fedora 22
boost-devel
 
FreeBSD
All Versions
boost-python-libs
 
Gentoo Linux
All Versions
dev-libs/boost
 
Mandrake/Mandriva Linux
All Versions
Not available
 
openSUSE
All Versions
boost-devel
 
Mac OS X
Leopard
boost boost-python
Snow Leopard
boost boost-python
Lion
boost boost-python
Mountain lion
boost boost-python
Mavericks
boost boost-python
Yosemite
boost boost-python
 
Red Hat Enterprise Linux
All Versions
boost-devel
 
Ubuntu
Karmic
Not available
Lucid
libboost1.40-all-dev
Maverick
libboost1.42-all-dev
Natty
libboost1.42-all-dev
Oneiric
libboost1.46-all-dev
Precise
libboost-all-dev
Quantal
libboost-all-dev
Raring
libboost-all-dev
Saucy
libboost-all-dev
Trusty
libboost-all-dev
Trusty (Python3)
libboost-all-dev
Utopic
libboost-all-dev
Utopic (Python3)
Not available
Vivid
libboost-all-dev
Vivid (Python3)
Not available
Wily
libboost-all-dev
Wily (Python3)
Not available
Xenial
libboost-all-dev
Xenial (Python3)
Not available
 

Raw Rosdep Data

  {"arch"=>["boost"], "cygwin"=>["libboost-devel", "libboost1.40"], "debian"=>{"jessie"=>["libboost-all-dev"], "sid"=>["libboost-all-dev"], "squeeze"=>["libboost1.42-all-dev"], "wheezy"=>["libboost-all-dev"]}, "fedora"=>["boost-devel"], "freebsd"=>["boost-python-libs"], "gentoo"=>["dev-libs/boost"], "macports"=>["boost"], "opensuse"=>["boost-devel"], "rhel"=>["boost-devel"], "ubuntu"=>{"lucid"=>{"apt"=>{"packages"=>["libboost1.40-all-dev"]}}, "maverick"=>{"apt"=>{"packages"=>["libboost1.42-all-dev"]}}, "natty"=>{"apt"=>{"packages"=>["libboost1.42-all-dev"]}}, "oneiric"=>{"apt"=>{"packages"=>["libboost1.46-all-dev"]}}, "precise"=>{"apt"=>{"packages"=>["libboost-all-dev"]}}, "quantal"=>{"apt"=>{"packages"=>["libboost-all-dev"]}}, "raring"=>{"apt"=>{"packages"=>["libboost-all-dev"]}}, "saucy"=>{"apt"=>{"packages"=>["libboost-all-dev"]}}, "trusty"=>{"apt"=>{"packages"=>["libboost-all-dev"]}}, "trusty_python3"=>{"apt"=>{"packages"=>["libboost-all-dev"]}}, "utopic"=>{"apt"=>{"packages"=>["libboost-all-dev"]}}, "vivid"=>{"apt"=>{"packages"=>["libboost-all-dev"]}}, "wily"=>{"apt"=>{"packages"=>["libboost-all-dev"]}}, "xenial"=>{"apt"=>{"packages"=>["libboost-all-dev"]}}}, "osx"=>{"homebrew"=>{"packages"=>["boost", "boost-python"]}}}
      

Used in Packages

Package usage not currently computed.